go下载指定版本的依赖包图文详解(go下载依赖包)学到了吗

随心笔谈1年前 (2023)发布 admin
103 0



目录前言1、进入github依赖包官网2、确认go语言的版本号3、在go.mod里添加tag字段4、拉取依赖包总结

在go语言开发中,要下载各种各样的依赖包,这些依赖包版本有的以vX.YY.ZZ结尾,有的以v0.0.0-20160315200505-970db520ece7结尾。这里以下载github.com/btcsuite/btcd v0.21.0-beta版本为例,进行说明。

在浏览器里输入:github.com/btcsuite/btcd 回车 –》点击 github左侧的Release –》Tags –》拷贝v0.21.0-beta,如图(1)、(2)所示:

图(1) 进入btcd的官网

图(2) 选中对应的Tags

点击 v0.21.0-beta标签 –》Browse Files –》Requirements列表里,就有go语言的最低版本号,如图(3)、图(4)、图(5)

图(3) 点击版本号下面的6位数分支链接

图(4) 点击[Browse files]

图(5) go版本至少1.12以上

说明 btcd v0.21.0-beta包所需要的go语言版本:1.12及以上,即go 1.12、1.13、1.14等版本都支持btcd,只要它在1.12版本号之上即可,这里选择go 1.13

//go.mod

module schnorrTwo
go 1.13
require github.com/btcsuite/btcd v0.21.0-beta
go mod tidy

图(6) 依赖包,默认放在 pkg/mod/github.com 目录下

到此这篇关于go下载指定版本的依赖包的文章就介绍到这了,更多相关go下载指定版本依赖包内容请搜索脚本之家以前的文章或继续浏览下面的相关文章希望大家以后多多支持脚本之家!

您可能感兴趣的文章:golang 如何自动下载所有依赖包go自动下载所有的依赖包go module使用详解

© 版权声明

相关文章